Details

    Description

      Recently, jbosstools-jst was updated to depend on a version of angularJS which is only available in our EA site, and therefore installation from the composite site fails unless we add that URL when installing.

         [p2.dir] Cannot complete the install because one or more required items could not be found.
         [p2.dir]  Software being installed: JBoss Tools Java Standard Tools Tests Developer Resources 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.source.feature.group 3.7.1.Beta1-v20151204-1915-B61)
         [p2.dir]  Missing requirement: Tests Plug-in 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.angularjs.test 3.7.1.Beta1-v20151204-1915-B61) requires 'bundle org.eclipse.angularjs.core 1.1.0' but it could not be found
         [p2.dir]  Cannot satisfy dependency:
         [p2.dir]   From: JBoss Tools Java Standard Tools Tests 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.feature.group 3.7.1.Beta1-v20151204-1915-B61)
         [p2.dir]   To: org.jboss.tools.jst.angularjs.test [3.7.1.Beta1-v20151204-1915-B61]
         [p2.dir]  Cannot satisfy dependency:
         [p2.dir]   From: JBoss Tools Java Standard Tools Tests Developer Resources 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.source.feature.group 3.7.1.Beta1-v20151204-1915-B61)
         [p2.dir]   To: org.jboss.tools.jst.test.feature.feature.group [3.7.1.Beta1-v20151204-1915-B61]
         [p2.dir] Application failed, log file location: /mnt/hudson_workspace/workspace/jbosstools-composite-install_4.3.mars/eclipse/configuration/1449257171806.log
         [p2.dir] Installation failed.
         [p2.dir] !SESSION 2015-12-04 14:26:11.552 -----------------------------------------------
         [p2.dir] eclipse.buildId=4.5.1.M20150904-0015
      --
         [p2.dir] !MESSAGE Cannot complete the install because one or more required items could not be found.
         [p2.dir] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2015-12-04 14:27:05.880
         [p2.dir] !MESSAGE Software being installed: JBoss Tools Java Standard Tools Tests Developer Resources 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.source.feature.group 3.7.1.Beta1-v20151204-1915-B61)
         [p2.dir] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2015-12-04 14:27:05.881
         [p2.dir] !MESSAGE Missing requirement: Tests Plug-in 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.angularjs.test 3.7.1.Beta1-v20151204-1915-B61) requires 'bundle org.eclipse.angularjs.core 1.1.0' but it could not be found
         [p2.dir] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 1 2015-12-04 14:27:05.881
         [p2.dir] !MESSAGE Cannot satisfy dependency:
         [p2.dir] !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2015-12-04 14:27:05.881
         [p2.dir] !MESSAGE From: JBoss Tools Java Standard Tools Tests 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.feature.group 3.7.1.Beta1-v20151204-1915-B61)
      --
         [p2.dir] !MESSAGE Cannot satisfy dependency:
         [p2.dir] !SUBENTRY 2 org.eclipse.equinox.p2.director 4 0 2015-12-04 14:27:05.881
         [p2.dir] !MESSAGE From: JBoss Tools Java Standard Tools Tests Developer Resources 3.7.1.Beta1-v20151204-1915-B61 (org.jboss.tools.jst.test.feature.source.feature.group 3.7.1.Beta1-v20151204-1915-B61)
      

      Attachments

        Issue Links

          Activity

            People

              alexeykazakov Alexey Kazakov
              nickboldt Nick Boldt
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: