Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-21001

Version of AngularJS in Central is older than version used in jbosstools-jst

    XMLWordPrintable

    Description

    Version of AngularJS used to build jbosstools-jst [1]:

    • 1.0.0.201508312121

    [1] https://github.com/jbosstools/jbosstools-jst/blob/jbosstools-4.3.x/pom.xml#L28

    Version of AngularJS (angularjs-eclipse-feature) included in Early Access site [2] for JBT 4.3.0.Final / JBDS 9.0.0.GA:

    • 0.10.0.201506182210

    [2] https://github.com/jbosstools/jbosstools-discovery/blob/jbosstools-4.3.x/jbtearlyaccesstarget/multiple/jbtearlyaccess-multiple.target#L11

    So, we should put the newer AngularJS in the EA site.

    But... it seems that the org.jboss.tools.jst.angularjs features & plugins don't actually depend on any of these:

    org.eclipse.angularjs.ui_1.0.0.201508312121.jar
    org.eclipse.angularjs.core_1.0.0.201508312121.jar
    angularjs-eclipse-feature_1.0.0.201508312121.jar
    

    So... other than the JBT/JBDS EA connectors, I can't see any reference to a specific version of angular, which begs the question: why does the jbosstools-jst build declare a dependency [3] on a specific update site mirror, such as [4] ?

    [3] https://github.com/jbosstools/jbosstools-jst/blob/jbosstools-4.3.x/pom.xml#L23-L29

    [4] http://download.jboss.org/jbosstools/updates/requirements/angularjs/1.0.0.201508312121/

      Attachments

        Issue Links

          Activity

            People

            Assignee:
            nickboldt Nick Boldt
            Reporter:
            nickboldt Nick Boldt
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: