Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-11476

JAX-RS Tools, Maven JAX-RS Configurator and WebServices cannot be installed on Juno

    XMLWordPrintable

Details

    • Hide

      EXEC: Install Eclipse Marketspace client in Juno

      1. EXEC: Find JBossTools Indigo in Eclipse marketspace
      2. EXEC: Start installation
      3. ASSERT: It resolves all required dependencies and let you continue

      Now it fails on step 3 with message in description of this issue

      Show
      EXEC: Install Eclipse Marketspace client in Juno EXEC: Find JBossTools Indigo in Eclipse marketspace EXEC: Start installation ASSERT: It resolves all required dependencies and let you continue Now it fails on step 3 with message in description of this issue
    • Hide

      Clear selection for JAX-RS Tools, Maven JAX-RS Configurator, WebServices and press Next button again

      Show
      Clear selection for JAX-RS Tools, Maven JAX-RS Configurator, WebServices and press Next button again

    Description

      Cannot complete the install because of a conflicting dependency.
        Software being installed: JBoss WebServices Tools 1.2.2.v20120323-1522-H83-Beta2 (org.jboss.tools.ws.feature.feature.group 1.2.2.v20120323-1522-H83-Beta2)
        Software currently installed: Eclipse SDK 4.2.0.I20120127-1145 (org.eclipse.sdk.ide 4.2.0.I20120127-1145)
        Only one of the following can be installed at once: 
          Core Resource Management 3.6.0.v20100526-0737 (org.eclipse.core.resources 3.6.0.v20100526-0737)
          Core Resource Management 3.8.0.v20120229-1128 (org.eclipse.core.resources 3.8.0.v20120229-1128)
          Core Resource Management 3.8.0.v20120120-1053 (org.eclipse.core.resources 3.8.0.v20120120-1053)
          Core Resource Management 3.6.1.R36x_v20110131-1630 (org.eclipse.core.resources 3.6.1.R36x_v20110131-1630)
          Core Resource Management 3.7.101.v20120125-1505 (org.eclipse.core.resources 3.7.101.v20120125-1505)
          Core Resource Management 3.6.0.R36x_v20100825-0600 (org.eclipse.core.resources 3.6.0.R36x_v20100825-0600)
          Core Resource Management 3.7.100.v20110510-0712 (org.eclipse.core.resources 3.7.100.v20110510-0712)
        Cannot satisfy dependency:
          From: Eclipse Platform 4.2.0.v20120112-2236-9IF7FH9EFwCXK_YKFP1XVz-xAsGJFz0QMKdek4UHk9aCo (org.eclipse.platform.feature.group 4.2.0.v20120112-2236-9IF7FH9EFwCXK_YKFP1XVz-xAsGJFz0QMKdek4UHk9aCo)
          To: org.eclipse.core.resources [3.8.0.v20120120-1053]
        Cannot satisfy dependency:
          From: Eclipse Project SDK 4.2.0.v20120109-2249-7T7mA7F8Yw_bnhbk55x4C6D3D7TtTxFPcwnkjP2xF9RDp (org.eclipse.sdk.feature.group 4.2.0.v20120109-2249-7T7mA7F8Yw_bnhbk55x4C6D3D7TtTxFPcwnkjP2xF9RDp)
          To: org.eclipse.platform.feature.group [4.2.0.v20120112-2236-9IF7FH9EFwCXK_YKFP1XVz-xAsGJFz0QMKdek4UHk9aCo]
        Cannot satisfy dependency:
          From: Eclipse SDK 4.2.0.I20120127-1145 (org.eclipse.sdk.ide 4.2.0.I20120127-1145)
          To: org.eclipse.sdk.feature.group [4.2.0.v20120109-2249-7T7mA7F8Yw_bnhbk55x4C6D3D7TtTxFPcwnkjP2xF9RDp]
        Cannot satisfy dependency:
          From: JBossWS Core 1.2.2.v20120323-1522-H83-Beta2 (org.jboss.tools.ws.core 1.2.2.v20120323-1522-H83-Beta2)
          To: bundle org.eclipse.core.resources [3.7.0,3.8.0)
        Cannot satisfy dependency:
          From: JBoss WebServices Tools 1.2.2.v20120323-1522-H83-Beta2 (org.jboss.tools.ws.feature.feature.group 1.2.2.v20120323-1522-H83-Beta2)
          To: org.jboss.tools.ws.core [1.2.2.v20120323-1522-H83-Beta2]

      Attachments

        Issue Links

          Activity

            People

              jjankovi Jaroslav Jankovič (Inactive)
              nivologd@gmail.com Denis Golovin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: