Step 1 of 4: Choose Issues

Cancel

T Key Summary Assignee Reporter Status Created Updated Components Description
Sub-task ENTESB-4953

ENTESB-4921 incorrect version imports in features:install camel-spring-security

Andrea Cosentino Josef Ludvicek (Inactive) Closed Camel, Karaf

Fuse provides spring 3.2.12.RELEASE
but camel-spring-security requires 3.2.13.RELEASE

JBossFuse:karaf@root> exports | grep org.springframework.core.io
   192 org.springframework.core.io; version=3.2.12.RELEASE
   192 org.springframework.core.io.support; version=3.2.12.RELEASE

JBossFuse:karaf@root> features:install camel-spring-security
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):                                                                                                                                                                                          
---------------------------                                                                                                                                                                                          
   package:(&(package=org.springframework.security.access)(version>=3.0.0)(!(version>=4.0.0)))                                                                                                                       
      camel-spring-security                                                                                                                                                                                          
   package:(&(package=org.springframework.core.io)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                      
      Spring Security Core                                                                                                                                                                                           
   package:(&(package=org.springframework.context.event)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                
      Spring Security Core                                                                                                                                                                                           
   package:(&(package=org.springframework.beans.propertyeditors)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                        
      Spring Security Core                                                                                                                                                                                           
   package:(&(package=org.springframework.core)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                         
      Spring Security Core                                                                                                                                                                                           
   package:(&(package=org.springframework.security.access.event)(version>=3.0.0)(!(version>=4.0.0)))
      camel-spring-security
   package:(&(package=org.springframework.security.core.context)(version>=3.0.0)(!(version>=4.0.0)))
      camel-spring-security
   package:(&(package=org.springframework.util)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.security.core)(version>=3.0.0)(!(version>=4.0.0)))
      camel-spring-security
   package:(&(package=org.springframework.context.expression)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.context)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.context.support)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.core.annotation)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.core.task)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.security.authentication)(version>=3.0.0)(!(version>=4.0.0)))
      camel-spring-security
   package:(&(package=org.springframework.beans.factory)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
   package:(&(package=org.springframework.beans)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
      Spring Security Core
Sub-task ENTESB-4949

ENTESB-4921 fix jclouds version for camel-jclouds

Andrea Cosentino Josef Ludvicek (Inactive) Closed Camel, Karaf

Fuse 6.3 build 015 contains redhat build of jclouds: 1.9.1.redhat-001
but camel-jclouds depend on jclouds version 1.9.1.

JBossFuse:karaf@root> features:install camel-jclouds
Error executing command: No feature named 'jclouds' with version '1.9.1' available

JBossFuse:karaf@root> features:info camel-jclouds
Description of camel-jclouds 2.16.1.redhat-630015 feature
----------------------------------------------------------------
Feature has no configuration
Feature has no configuration files
Feature depends on:
  jclouds 1.9.1
  jclouds-blobstore 1.9.1
  jclouds-compute 1.9.1
  camel-core 2.16.1.redhat-630015
Feature contains followed bundles:
 mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.jsr311-api-1.1.1/2.5.0 start-level=50
 mvn:org.apache.camel/camel-jclouds/2.16.1.redhat-630015 start-level=50
Feature has no conditionals.
JBossFuse:karaf@root> features:info jclouds
Description of jclouds 1.9.1.redhat-001 feature
 jclouds
----------------------------------------------------------------
Feature has no configuration
Feature has no configuration files
Feature depends on:
  jclouds-guice 1.9.1.redhat-001
Feature contains followed bundles:
 mvn:com.google.guava/guava/16.0
 mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.oauth-commons/20100527_1
 mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jersey-core/1.11_1
 mvn:com.google.code.gson/gson/2.3
 mvn:org.apache.jclouds/jclouds-core/1.9.1
Feature has no conditionals.
Sub-task ENTESB-4947

ENTESB-4921 missing package org.eclipse.jetty.server.ssl for features:install camel-cometd

Unassigned Josef Ludvicek (Inactive) Closed Camel, Karaf
JBossFuse:karaf@root> features:install camel-cometd
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.eclipse.jetty.server.ssl)(version>=8.0.0)(!(version>=10.0.0)))
      camel-cometd

JBossFuse:karaf@root> features:install camel-websocket
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.eclipse.jetty.server.ssl)(version>=8.0.0)(!(version>=10.0.0)))
      camel-websocket
   package:(&(package=org.eclipse.jetty.websocket)(version>=8.0.0)(!(version>=10.0.0)))
      camel-websocket
   package:(&(package=org.eclipse.jetty.http.ssl)(version>=8.0.0)(!(version>=10.0.0)))
      camel-websocket

Affected features

  • camel-cometd
  • camel-websocket
Sub-task ENTESB-4945

ENTESB-4921 missing requirement for features:install switchyard-soap

Thomas Cunningham Josef Ludvicek (Inactive) Closed Karaf, SwitchYard

Can't install following features on fuse 6.3 build 015

  • switchyard-soap
  • switchyard-quickstart-bpel-loan-approval
  • switchyard-quickstart-bpel-say-hello
  • switchyard-quickstart-bpel-simple-correlation
  • switchyard-quickstart-bean-service
  • switchyard-quickstart-camel-bus-cdi
JBossFuse:karaf@root> features:install switchyard-soap
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.eclipse.jetty.plus.jaas))
      SwitchYard: SOAP Component
Sub-task ENTESB-4944

ENTESB-4921 Can't install switchyard-http

Thomas Cunningham Josef Ludvicek (Inactive) Closed Karaf, SwitchYard

Steps to reproduce

  • start fuse
  • features:install switchyard-http
    JBossFuse:karaf@root> features:install switchyard-http
    Error executing command: Can not resolve feature:
    Unsatisfied requirement(s):
    ---------------------------
       package:(&(package=org.switchyard.component.common.composer)(version>=2.1.0)(!(version>=2.2.0)))
          SwitchYard: HTTP Component
       package:(&(package=org.switchyard.component.common.label)(version>=2.1.0)(!(version>=2.2.0)))
          SwitchYard: HTTP Component
       package:(&(package=org.switchyard.component.common)(version>=2.1.0)(!(version>=2.2.0)))
          SwitchYard: HTTP Component
       package:(&(package=org.switchyard.component.common.selector)(version>=2.1.0)(!(version>=2.2.0)))
          SwitchYard: HTTP Component
    
Sub-task ENTESB-4943

ENTESB-4921 missing requirement for feature camel-amqp

Andrea Cosentino Josef Ludvicek (Inactive) Closed Camel, Karaf
  • Start fuse
  • features:install camel-amqp
JBossFuse:karaf@root> features:install switchyard-amqp
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.apache.qpid.amqp_1_0.jms.impl)(version>=0.20.0)(!(version>=1.0.0)))
      camel-amqp

JBossFuse:karaf@root> features:list | grep amqp
[uninstalled] [2.1.0.redhat-630015  ] switchyard-amqp                               switchyard-2.1.0.redhat-630015         
[uninstalled] [2.1.0.redhat-630015  ] switchyard-quickstart-camel-amqp-binding      switchyard-2.1.0.redhat-630015         
[uninstalled] [2.16.1.redhat-630015 ] camel-amqp                                    camel-2.16.1.redhat-630015             

JBossFuse:karaf@root> features:install camel-amqp
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.apache.qpid.amqp_1_0.jms.impl)(version>=0.20.0)(!(version>=1.0.0)))
      camel-amqp

Features affected

  • camel-amqp
  • switchyard-amqp
Sub-task ENTESB-4926

ENTESB-4921 can't install features cxf-rs-description-swagger2 and camel-swagger-java

Andrea Cosentino Josef Ludvicek (Inactive) Closed Karaf

Can't install features

  • camel-swagger-java
  • cxf-rs-description-swagger2

due to wiring chain issues with package com.google.common.base

JBossFuse:karaf@root> features:install cxf-rs-description-swagger2
Error executing command: Could not start bundle mvn:io.swagger/swagger-jaxrs/1.5.4 in feature(s) camel-swagger-java-2.16.1.redhat-630015, cxf-rs-description-swagger2-3.1.4: Uses constraint violation. Unable to resolve bundle revision io.swagger.jaxrs [294.0] because it is exposed to package 'com.google.common.base' from bundle revisions com.google.guava [301.0] and com.google.guava [159.0] via two dependency chains.

Chain 1:
  io.swagger.jaxrs [294.0]
    import: (&(osgi.wiring.package=com.google.common.base)(version>=18.0.0)(!(version>=19.0.0)))
     |
    export: osgi.wiring.package=com.google.common.base
  com.google.guava [301.0]

Chain 2:
  io.swagger.jaxrs [294.0]
    import: (osgi.wiring.package=org.reflections.util)
     |
    export: osgi.wiring.package=org.reflections.util; uses:=com.google.common.collect
  org.apache.servicemix.bundles.reflections [142.0]
    import: (osgi.wiring.package=com.google.common.collect)
     |
    export: osgi.wiring.package=com.google.common.collect; uses:=com.google.common.base
    export: osgi.wiring.package=com.google.common.base
  com.google.guava [159.0]

JBossFuse:karaf@root> osgi:list -l -t 0 | grep '(294|159|301|142)'
[ 142] [Active     ] [            ] [       ] [   80] mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.reflections/0.9.8_1
[ 159] [Active     ] [            ] [       ] [   80] mvn:com.google.guava/guava/17.0
Sub-task ENTESB-4923

ENTESB-4921 missing requirements for features:install cxf-rs-security-jose

Andrea Cosentino Josef Ludvicek (Inactive) Closed CXF, Karaf

Probably missing dependency in features.xml for Apache CXF Runtime JOSE Core

Steps to reproduce

  • start fuse
  • features:install cxf-rs-security-jose
JBossFuse:karaf@root> features:install  cxf-rs-security-jose 
Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.apache.cxf.jaxrs.json.basic)(version>=3.1.0)(!(version>=4.0.0)))
      Apache CXF Runtime JOSE Core

Affected features

  • cxf-rs-security-jose
  • cxf-rs-security-oauth2
Sub-task ENTESB-4922

ENTESB-4921 can't install feature cxf *ws* features due to problematic org.joda.time import

Andrea Cosentino Josef Ludvicek (Inactive) Closed CXF, Karaf

Two dependency chains for org.joda.time package

Found in: JBoss Fuse (6.3.0.redhat-015)

Steps to reproduce

  • start fuse
  • features:install wss4j
JBossFuse:karaf@root> features:install wss4j 
Error executing command: Could not start bundle mvn:org.apache.wss4j/wss4j-ws-security-policy-stax/2.1.4 in feature(s) wss4j-2.1.4: Uses constraint violation. Unable to resolve bundle revision org.apache.wss4j.wss4j-ws-security-stax [303.0] because it is exposed to package 'org.joda.time' from bundle revisions joda-time [295.0] and joda-time [216.0] via two dependency chains.                                                

Chain 1:                                                                                                                                                                                                             
  org.apache.wss4j.wss4j-ws-security-stax [303.0]                                                                                                                                                                    
    import: (&(osgi.wiring.package=org.joda.time)(version>=2.7.0)(!(version>=3.0.0)))                                                                                                                                
     |                                                                                                                                                                                                               
    export: osgi.wiring.package=org.joda.time                                                                                                                                                                        
  joda-time [295.0]

Chain 2:
  org.apache.wss4j.wss4j-ws-security-stax [303.0]
    import: (osgi.wiring.package=org.opensaml.xmlsec.signature.support)
     |
    export: osgi.wiring.package=org.opensaml.xmlsec.signature.support; uses:=org.joda.time
  org.apache.servicemix.bundles.opensaml [294.0]
    import: (&(osgi.wiring.package=org.joda.time)(version>=2.2.0)(!(version>=3.0.0)))
     |
    export: osgi.wiring.package=org.joda.time
  joda-time [216.0]

Affected features

  • cxf
  • wss4j
  • cxf-ws-security
  • cxf-rt-security-saml
  • cxf-rs-security-xml
  • cxf-rs-security-sso-saml

Cancel