Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-15838

Upgrade to Hibernate Search 6.1

XMLWordPrintable

      This is required for WFLY-15440: only Hibernate Search 6.1 will be compatible with Hibernate ORM 6 and Jakarta EE (thanks to dedicated artifacts).

      This is also necessary simply to get WildFly up to speed with the latest advances of Hibernate Search, most notably the introduction of an Elasticsearch backend that allows distributed applications to target indexes in a remote Elasticsearch cluster.

      New features in Hibernate Search 6.0: https://hibernate.org/search/releases/6.0/#whats-new

      New features in Hibernate Search 6.1: https://hibernate.org/search/releases/6.1/#whats-new

      Migration guide (from 5.11 to 6.0, but 5.10 to 6.1 would be the same): https://docs.jboss.org/hibernate/search/6.0/migration/html_single/

       

            rh-ee-yrodiere Yoann Rodière
            rh-ee-yrodiere Yoann Rodière
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Created:
              Updated:
              Resolved: