Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-10467

Drop support for mod_cluster subsystem model versions prior 1.5.0

    XMLWordPrintable

Details

    • Task
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Done
    • 13.0.0.Beta1, 13.0.0.Final
    • 14.0.0.Beta2
    • mod_cluster
    • None

    Description

      • No need to keep unused model version 1.4.0 in enumeration.
      • No need to keep transformer logic prior 1.5.0 which is the lowest supported (session draining strategy was supported in EAP 6.3/6.4 so no need to transform to older).
      • No need for org.wildfly.extension.mod_cluster.controller.SessionDrainingStrategyChecker
      • No need for 1.5.0 config in org.wildfly.extension.mod_cluster.ModClusterTransformersTestCase#createFailedOperationConfig

      Attachments

        Issue Links

          Activity

            People

              rhn-engineering-rhusar Radoslav Husar
              rhn-engineering-rhusar Radoslav Husar
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: