It's a few years before we'll get to 8.0, but we need to start gathering these now as 7.0 is going into CR1.
- ValueSelectorConfig.variableName should no longer work as a nested element too. (
- Rename AcceptorConfig to LocalSearchAcceptorConfig (similarly for deciders, foragers)... (
- Ideally, for 8.0 (or 9.0) we remove all non-getter/setters of the config classes while we internalize the SolverConfig in the SolverFactory. (maybe Radovan)
Things to consider:
- directory name != artifactId to avoid windows path 260 issue and to have quarkus/spring a submodule of integration
- Rename <scoreDirectorFactory> to <scoring>?
- Rename ScoreManager to SolutionManager to accomodate retriggerAllVariableListeners() too? (Are we giving the users a way to shoot them in the foot? Can we not just retrigger them every time? It's an ugly duckling: retriggerAllVariableListeners(), calculateScore(), getIndictmentMap(), ...)