-
Epic
-
Resolution: Unresolved
-
Major
-
None
-
None
-
None
-
None
-
10.0 backwards incompatible changes for next major version
-
To Do
-
Undefined
-
NEW
-
NEW
List:
- Move LookUpStrategyType and PlanningId from package "domain.lookup" to package "domain.common"
- Should Score, SolverStatus, Indictment etc be in a separate "shared jar" with a different package name? (They are the few ones you need in a remote solver use case.)
- Remove "quarkus." prefix of "quarkus.optaplanner..." application.properties
- CS from() is deprecated, just remove it.
- SolverManager<Solution_> (instead of <Solution_, ProblemId_>) but still have SolverJob<Solution_, ProblemId_>. Methods:
- <ProblemId> SolverJob<Solution_, ProblemId_> solve(ProblemId_ problemId, ...) ...
- <ProblemId> SolverStatus getSolverStatus(ProblemId_ problemId);
- <ProblemId> void terminateEarly(ProblemId_ problemId);
- Create an API JAR separate from the core JAR.
- CS API should be moved to the CS JAR.
- Remove DRL.
- Make CS-D optional, not ship by default.
- incorporates
-
PLANNER-2676 IncrementalScoreCalculator support for problem fact add/change/remove
- Open
-
PLANNER-2587 Quarkus/Spring: Deprecate-rename solverConfig.xml to optaplannerSolver.xml and solverBenchmarkConfig.xml to optaplannerBenchmark.xml
- Open
- is blocked by
-
PLANNER-2615 Create standalone optaplanner-core-api module
- Closed