Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-6764

Add Git Repository form shows empty permission content and non-working help link until a git url is entered

XMLWordPrintable

    • Informational
    • ODC Sprint 231
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None
    • NA

      Description of problem:
      The "Add Git Repository" has a "Show configuration options" expandable section that shows the required permissions for a webhook setup, and provides a link to "read more about setting up webhook".

      But the permission section shows nothing when open this second expandable section, and the link doesn't do anything until the user enters a "supported" GitHub, GitLab or BitBucket URL.

      Version-Release number of selected component (if applicable):
      4.11-4.13

      How reproducible:
      Always

      Steps to Reproduce:

      1. Install Pipelines operator
      2. Navigate to the Developer perspective > Pipelines
      3. Press "Create" and select "Repository"
      4. Click on "Show configuration options"
      5. Click on "See Git permissions"
      6. Click on "Read more about setting up webhook"

      Actual results:

      1. The Git permission section shows no git permissions.
      2. The Read more link doesn't open any new page.

      Expected results:

      1. The Git permission section should show some info or must not be disabled.
      2. The Read more link should open a page or must not be displayed as well.

      Additional info:

      1. None

            cjerolim Christoph Jerolimov
            cjerolim Christoph Jerolimov
            Sanket Pathak Sanket Pathak
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Created:
              Updated:
              Resolved: