Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-4824

Sandbox UI times out when creating or deleting helm chart

    XMLWordPrintable

Details

    • Bug
    • Resolution: Done
    • Normal
    • 4.13
    • 4.11.z
    • Dev Console
    • Moderate
    • ODC Sprint 232
    • 1
    • Rejected
    • False
    • Hide

      None

      Show
      None

    Description

      Description of problem: To me it looks like the UI gave up waiting for the install but so it does not show the correct state that the help chart has been deployed. Leading to the user clicking install again and getting the resource name error.

      Steps to Reproduce:

      1.Create a new container from a helm chart, I was making Jenkins.
      2. During the install you will get an error saying gateway timeout.
      3. The UI will look as if the install never happened.
      4. You click install again and you get a different error saying you have have two resource with the same name.
      5. The helm chart has deployed
      

      Actual results:

      The UI timesout leaving the UI in an unknown state.

      Expected results:

      UI Will let you know the install is done

      Additional info: 

      Slack Thread

      Recording of reproduction

      Attachments

        Issue Links

          Activity

            People

              dsantra12 Debsmita Santra
              bbazemor Brad Bazemore
              Sanket Pathak Sanket Pathak
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: