Uploaded image for project: 'OpenShift Bugs'
  1. OpenShift Bugs
  2. OCPBUGS-2900

fix(openshift): use env var instead of clusterversion status

XMLWordPrintable

    • Icon: Bug Bug
    • Resolution: Done
    • Icon: Minor Minor
    • None
    • 4.11.z
    • OLM
    • None
    • False
    • Hide

      None

      Show
      None

      This bug is to establish the current-version OCP downstream as an OCPBUGS anchor issue for backporting. It is a duplicate of this issue.

      -------------------------------------------------------------

      Description of problem:
      Cluster attempted to upgrade from 4.9.29 -> 4.10.15. The upgrade could not progress because of:

      Last Transition Time: 2022-06-15T16:08:33Z
      Message: ClusterServiceVersions blocking cluster upgrade: redhat-rhoam-operator/managed-api-service.v1.22.0 is incompatible with OpenShift minor versions greater than 4.10
      Reason: IncompatibleOperatorsInstalled
      Status: False
      Type: Upgradeable

      The mentioned CSV has olm.maxOpenShiftVersion of 4.10:

      *

      { "type": "olm.maxOpenShiftVersion", "value": "4.10" }

      *

      Actual results:
      The upgrade is blocked on this olm.maxOpenShiftVersion

      Expected results:
      The upgrade should not be blocked on this olm.maxOpenShiftVersion

      Additional info:
      The particular customer has successfully upgraded twice on different clusters on the same OCP edge and with managed-api-service.v1.22.0 installed

      must-gather will be attached in a private comment

            pegoncal@redhat.com Per Goncalves da Silva
            rh-ee-cchantse Catherine Chan-Tse
            Kui Wang Kui Wang
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Created:
              Updated:
              Resolved: