Uploaded image for project: 'jBPM'
  1. jBPM
  2. JBPM-9680

Stunner - Sub-process linked to itself doesn't perform any action

    XMLWordPrintable

Details

    • Bug
    • Resolution: Unresolved
    • Major
    • None
    • 7.52.0.Final
    • Designer
    • False
    • False
    • NEW
    • NEW
    • Undefined
    • Hide
      1. Create a process testing-process.
      2. Drag and drop reusable sub-process to canvas.
      3. Set Called element property to testing-process.
      4. Click on "Open sub-process" icon in reusable sub-process.

      Actual result

      Nothing happens.

      Expected result

      An info message is shown with the message that the process is already open.

      Show
      Create a process testing-process . Drag and drop reusable sub-process to canvas. Set Called element property to testing-process . Click on "Open sub-process" icon in reusable sub-process. Actual result Nothing happens. Expected result An info message is shown with the message that the process is already open.

    Description

      If the process is linked to itself (the process where a reusable sub-process is placed) using sub-process's called element property, after clicking on "Open sub-process", nothing happens.

      There should be an info message shown that the process is already open.

      Attachments

        Issue Links

          Activity

            People

              romartin@redhat.com Roger Martinez
              lterifaj@redhat.com Lubomir Terifaj
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: