Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-14126

Weinre Inspector is showing no data within Elements tab

    XMLWordPrintable

Details

    Description

      1. Open www.amazon.com page in Browsersim
      2. Run Weinre Inspector via Browsersim context menu "Weinre"

      ERROR: No elements shown on Elements tab

      Client is connected:

      3. Run Weinre server locally.
      4. Set Browsersim to use local Weinre server
      5. Run Weinre Inspector as in step 2.

      ERROR: No elements shown on Elements tab

      Client is connected:

      6. Create HTML5 project from JBoss Central
      7. Insert script tag allowing debugging via local Weinre server to index.html
      8. Run HTML5 project on Server
      9. Open HTML5 index.html in system borwser

      ASSERT: Weinre debugging works

      ERROR: Weinre debugging is not working from JBDS internal browser

      10. Open index.html of HTML5 project in Browsersim
      11. Open Weinre debug link in Browser

      ERROR: No elements shown on Elements tab

      Client is connected:

      Attachments

        1. localamazon.png
          localamazon.png
          31 kB
        2. localbrowsersimhtml5.png
          localbrowsersimhtml5.png
          26 kB
        3. localhtml5.png
          localhtml5.png
          82 kB
        4. phonegapamazon.png
          phonegapamazon.png
          7 kB

        Issue Links

          Activity

            People

              kmarmaliykov Konstantin Marmalyukov (Inactive)
              vpakan Vlado Pakan (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: