Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-12668

Cannot install JBoss Tools 3.3.1 in Eclipse Indigo if egit 2.0 is already installed; cannot update to egit 2.0 if JBT 3.3.1 is installed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: 3.3.1.Final
    • Fix Version/s: 3.3.2.Final
    • Component/s: openshift
    • Labels:
      None
    • Workaround:
      Workaround Exists
    • Workaround Description:
      Hide

      Downgrade to EGit 1.3.

      Show
      Downgrade to EGit 1.3.

      Description

      The current release of the OpenShift Tools isn't compatible with the latest release of EGit, as reported by Eclipse:

      Cannot complete the install because of a conflicting dependency.
      Software being installed: Eclipse EGit 2.0.0.201206130900-r (org.eclipse.egit.feature.group 2.0.0.201206130900-r)
      Software currently installed: JBoss OpenShift Tools 2.3.1.v20120715-0255-H145-Final (org.jboss.tools.openshift.express.feature.feature.group 2.3.1.v20120715-0255-H145-Final)
      Only one of the following can be installed at once:
      Git Team Provider UI 2.0.0.201206130900-r (org.eclipse.egit.ui 2.0.0.201206130900-r)
      Git Team Provider UI 1.1.0.201109151100-r (org.eclipse.egit.ui 1.1.0.201109151100-r)
      Git Team Provider UI 1.3.0.201202151440-r (org.eclipse.egit.ui 1.3.0.201202151440-r)
      Git Team Provider UI 1.2.0.201112121913 (org.eclipse.egit.ui 1.2.0.201112121913)
      Git Team Provider UI 1.0.0.201106090707-r (org.eclipse.egit.ui 1.0.0.201106090707-r)
      Cannot satisfy dependency:
      From: Eclipse EGit 2.0.0.201206130900-r (org.eclipse.egit.feature.group 2.0.0.201206130900-r)
      To: org.eclipse.egit.ui [2.0.0.201206130900-r]
      Cannot satisfy dependency:
      From: JBoss OpenShift Tools 2.3.1.v20120715-0255-H145-Final (org.jboss.tools.openshift.express.feature.feature.group 2.3.1.v20120715-0255-H145-Final)
      To: org.jboss.tools.openshift.express.ui [2.3.1.v20120715-0255-H145-Final]
      Cannot satisfy dependency:
      From: OpenShift UI 2.3.1.v20120715-0255-H145-Final (org.jboss.tools.openshift.express.ui 2.3.1.v20120715-0255-H145-Final)
      To: bundle org.eclipse.egit.ui [1.0.0,2.0.0)

      Please advise.

        Attachments

        1. failed-to-upgrade-egit.png
          failed-to-upgrade-egit.png
          86 kB
        2. install-331-to-juno-1.png
          install-331-to-juno-1.png
          81 kB
        3. install-331-to-juno-2.png
          install-331-to-juno-2.png
          31 kB
        4. install-331-to-juno-3.png
          install-331-to-juno-3.png
          63 kB
        5. install-openshift-to-indigo-1.png
          install-openshift-to-indigo-1.png
          75 kB
        6. install-openshift-to-indigo-2.png
          install-openshift-to-indigo-2.png
          21 kB
        7. install-openshift-to-indigo-3.png
          install-openshift-to-indigo-3.png
          57 kB
        8. openshift-231-requires-egit-lt-20.png
          openshift-231-requires-egit-lt-20.png
          77 kB

          Issue Links

            Activity

              People

              Assignee:
              adietish André Dietisheim
              Reporter:
              fribeiro1 Fernando Ribeiro (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: