Uploaded image for project: 'Tools (JBoss Tools)'
  1. Tools (JBoss Tools)
  2. JBIDE-12307

unified.target appears broken

    XMLWordPrintable

Details

    Description

      Use of the unified.target fails as PDE target platform for both Indigo and Juno.

      Indigo IDE
      Use of the trunk version of unified.target results in org.lucene.core 3.5-4 not being found, which is true since only version 2.91 is available in the update site - http://download.jboss.org/jbosstools/updates/target-platform_3.4.juno.SR0/latest/plugins

      Juno IDE
      Use of the trunk version of unified.target results in package org.xmlpull.mxp1 not being found as a requirement of XStream.

      Both errors imply an incomplete target platform but does the fact that they are different errors imply that plugins in the installed IDE are assumed to be there?

      Should it not be possible to take an eclipse Indigo and develop against a Juno target platform?

      Attachments

        1. jbds-target-46269.png
          jbds-target-46269.png
          129 kB
        2. multiple-target-46269.png
          multiple-target-46269.png
          128 kB
        3. unified-target-46269.png
          unified-target-46269.png
          118 kB

        Issue Links

          Activity

            People

              nickboldt Nick Boldt
              parichar@redhat.com Paul Richardson
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: