Details

      Description

      The org.jboss.as.security module contains the implementation of the legacy security subsystem, however many other subsystems define a dependency on it.

      The risk of this module being present is if a server configuration is provisioned without legacy security the subsystem can be added back in using CLI commands - we are at the point however where new configurations will be expected to operate with WildFly Elytron exclusively.

      The majority of these dependencies are to reference defined constants, these can easily be duplicated to remove the dependency. There are also a few utility classes which can be split out into their own module.

      https://github.com/wildfly/wildfly/pull/13568

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  dlofthouse Darran Lofthouse
                  Reporter:
                  dlofthouse Darran Lofthouse
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: