Details

    • Sub-task
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • 2.0.0.Beta4
    • None
    • UI - Shell
    • None

    Description

      In FORGE-1394 there is a proposition of renaming bean-validation commands into constraint. It might be clear (e.g. NotEmpty is not part of Bean Validation but a proprietary Hibernate Validator) and shorter commands. So instead of :

      bean-validation-setup
      bean-validation-add-constraint --property room --constraint NotNull
      

      We should have

      constraint-setup
      constraint-add --property room --constraint NotNull
      

      And to reflect FORGE-1446 and FORGE-944 we should have

      constraint-add --named NotNull --onProperty room 
      

      Attachments

        Activity

          People

            Unassigned Unassigned
            agoncal Antonio Goncalves
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: