Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-15891

Upgrade to Undertow 2.2.5.Final-redhat-00001 and XNIO 3.8.4.Final-redhat-00001

    XMLWordPrintable

Details

    • Component Upgrade
    • Status: Done
    • Blocker
    • Resolution: Done
    • None
    • fuse-7.9-GA
    • Karaf
    • None

    Description

      After UNDERTOW-1852 is productized, we should switch to Undertow 2.2.x with OSGi support. This can be followed by XNIO update from 3.3.8 to 3.8.0. XNIO after 3.3.8 has 3 additional dependencies:

      • JBoss Threads
      • Wildfly Client Config
      • Wildfly Common

      tcunning@redhat.com, ldemasi, johnpoth https://ci-jenkins-csb-fuse.apps.ocp4.prod.psi.redhat.com/job/Fuse/job/productization-sb2-build/37/console is failing because karaf-camel-amq us using xnio version taken from redhat-fuse, which uses XNIO version 3.5.9 since ENTESB-14549.

      That's why feature verification fails.

      And unfortunately I won't fix it today before getting new Undertow. I can't also downgrade to XNIO 3.3.8.Final.

      Attachments

        Issue Links

          Activity

            People

              ggrzybek Grzegorz Grzybek
              ggrzybek Grzegorz Grzybek
              Federico Mariani Federico Mariani
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: