Uploaded image for project: 'Debezium'
  1. Debezium
  2. DBZ-2514

Add support for Cassandra 4.x

    XMLWordPrintable

Details

    Description

      Related to the comment here:

      https://github.com/debezium/debezium-incubator/blob/master/README.md#building-the-cassandra-3x-connector

      We currently only support Cassandra 3.x. Cassandra 3.x only supports Java 8 which means the Cassandra Connector can only be build with Java 8. We should upgrade to Cassandra 4.x dependencies and support of Cassandra 4+ in order to get Java >= 9 support.

      This will also contribute to DBZ-2513 "Add Java Outreach to incubator repository"

      Attachments

        Issue Links

          Activity

            People

              jpechane Jiri Pechanec
              rk3rn3r René Kerner
              Votes:
              1 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: