Uploaded image for project: 'Debezium'
  1. Debezium
  2. DBZ-2138

Upgrade MongoDB driver to 4.x to run in native mode in GraalVM (for Quarkus extension)

    XMLWordPrintable

Details

    Description

      I'm working on camel-quarkus debezium-mongodb -connector extension.
      Quarkus mongodb client uses driver 4.x (see https://github.com/quarkusio/quarkus/blob/master/bom/runtime/pom.xml#L161)
      Debezium uses driver of version 3.12.2.
      This unfortunatelly doesn't seem to be backcompatible, I'm getting a lot of java.lang.NoClassDefFoundError, because of different packages and missing classes.

      Upgrading version of mongodb driver will allow to create camel-quarkus extension.

      Attachments

        Issue Links

          Activity

            People

              jpechane Jiri Pechanec
              jondruse@redhat.com Jiri Ondrusek
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: