Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-95

Integration tests throw a StackOverflowError when using "java -client"

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: None
    • Fix Version/s: 8.0.0.Alpha1
    • Component/s: Test Suite
    • Labels:
      None

      Description

      See https://community.jboss.org/message/807403

      The integration tests use Arquillian and so do not pickup the '-server' flag that would normally be set in the standalone.sh. As a result the default is used (-server for 64bit and -client for 32bit.

      It was agreed that the fix is to make the integration tests explicit in that -server should be used.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  pferraro Paul Ferraro
                  Reporter:
                  paul.robinson Paul Robinson
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: