Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-8806

Elytron integration with the legacy JSSE domains is broken after the SSL-related capabilities were changed in Elytron

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 11.0.0.Alpha1
    • Fix Version/s: 11.0.0.Beta1
    • Component/s: Security
    • Labels:
      None

      Description

      The SSL-related capabilities have been changed in the Elytron subsystem (name and expected type of the key and trust managers, for example), which broke the integration with the legacy JSSE security domains.

      The integration has to be reworked to use the new capabilities names and types.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  sguilhen Stefan Guilhen
                  Reporter:
                  sguilhen Stefan Guilhen
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: