Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-7963

Require Maven 3.3.1+ and introduce mvnw

    XMLWordPrintable

Details

    • Task
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Done
    • None
    • 11.0.0.Alpha1
    • None
    • None

    Description

      • Maven 3.3.1+ is required by the Enforcer Plugin
      • mvnw (a.k.a. Maven Wrapper) replaces the legacy tools/download-maven.* scripts
      • build. and integration-tests. scripts were kept for backwards compatibility.

      These changes were discussed on wildfly-dev mailing list.

      Attachments

        Issue Links

          Activity

            People

              ppalaga Peter Palaga
              ppalaga Peter Palaga
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: