Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-7256

Configuration differences between default configuration and read/persisted in messaging and IIOP

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Done
    • 10.1.0.Final
    • 11.0.0.Alpha1
    • IIOP, JMS
    • None

    Description

      Following up on JBEAP-3093, there are still differences in these 2 subsystems:

      258a255
      >             <orb socket-binding="iiop" ssl-socket-binding="iiop-ssl"/>
      337c334
      <                     <role name="guest" delete-non-durable-queue="true" create-non-durable-queue="true" consume="true" send="true"/>
      ---
      >                     <role name="guest" send="true" consume="true" create-non-durable-queue="true" delete-non-durable-queue="true"/>
      339,341c336,338
      <                 <address-setting name="#" redistribution-delay="1000" message-counter-history-day-limit="10" page-size-bytes="2097152" max-size-bytes="10485760" expiry-address="jms.queue.ExpiryQueue" dead-letter-address="jms.queue.DLQ"/>
      <                 <http-connector name="http-connector" endpoint="http-acceptor" socket-binding="http"/>
      <                 <http-connector name="http-connector-throughput" endpoint="http-acceptor-throughput" socket-binding="http">
      ---
      >                 <address-setting name="#" dead-letter-address="jms.queue.DLQ" expiry-address="jms.queue.ExpiryQueue" max-size-bytes="10485760" page-size-bytes="2097152" message-counter-history-day-limit="10" redistribution-delay="1000"/>
      >                 <http-connector name="http-connector" socket-binding="http" endpoint="http-acceptor"/>
      >                 <http-connector name="http-connector-throughput" socket-binding="http" endpoint="http-acceptor-throughput">
      353c350
      <                 <cluster-connection name="my-cluster" discovery-group="dg-group1" connector-name="http-connector" address="jms"/>
      ---
      >                 <cluster-connection name="my-cluster" address="jms" connector-name="http-connector" discovery-group="dg-group1"/>
      356,358c353,355
      <                 <connection-factory name="InVmConnectionFactory" entries="java:/ConnectionFactory" connectors="in-vm"/>
      <                 <connection-factory name="RemoteConnectionFactory" reconnect-attempts="-1" block-on-acknowledge="true" ha="true" entries="java:jboss/exported/jms/RemoteConnectionFactory" connectors="http-connector"/>
      <                 <pooled-connection-factory name="activemq-ra" transaction="xa" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory" connectors="in-vm"/>
      ---
      >                 <connection-factory name="InVmConnectionFactory" connectors="in-vm" entries="java:/ConnectionFactory"/>
      >                 <connection-factory name="RemoteConnectionFactory" ha="true" block-on-acknowledge="true" reconnect-attempts="-1" connectors="http-connector" entries="java:jboss/exported/jms/RemoteConnectionFactory"/>
      >                 <pooled-connection-factory name="activemq-ra" transaction="xa" connectors="in-vm" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory"/>
      
      

      Attachments

        Issue Links

          Activity

            People

              jmesnil1@redhat.com Jeff Mesnil
              jmesnil1@redhat.com Jeff Mesnil
              Jan Kasik Jan Kasik
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: