Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-6856

Jboss CLI reporting wrong readings of datasource

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 8.2.0.Final
    • Fix Version/s: None
    • Component/s: JCA
    • Labels:
    • Steps to Reproduce:
      Hide

      1) Load the application server with request to shoot up the active count
      2) Reduce hte load
      Idle connections remain as-is and never seem to flush off.
      Triggering flush command isn't flushing-off the connections either. Instead, in some cases the connections seem to shoot up.

      Show
      1) Load the application server with request to shoot up the active count 2) Reduce hte load Idle connections remain as-is and never seem to flush off. Triggering flush command isn't flushing-off the connections either. Instead, in some cases the connections seem to shoot up.
    • Estimated Difficulty:
      High

      Description

      Jboss's CLI is reporting wrong values of datasource parameters.(active count,idlecount etc..)

      As per the reading , idle connections on the database side have been closed but actually the connections are indeed active.

      Probably, jboss isn't checking on the oracle side.

      PS : found in wildfly 8 and our db is Oracle

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jesper.pedersen Jesper Pedersen
                Reporter:
                nitritesh ritesh ranjan
                Tester:
                - -
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: