Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-3581

Remove EE Concurrency mandatory dependency on Transaction subsystem

    XMLWordPrintable

    Details

      Description

      Currently the EE subsystem requires the presence of Transactions subsystem, due to EE Concurrency requiring JTA's TransactionManager. This issue should fix that by moving all Transaction related code from EE to Transactions, and enhance EE Concurrency so it may work without JTA available.

        Attachments

          Activity

            People

            Assignee:
            emmartins Eduardo Martins
            Reporter:
            emmartins Eduardo Martins
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: