Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-15867

Upgrade org.xipki.pki/ocsp-server

    XMLWordPrintable

Details

    • Component Upgrade
    • Status: Pull Request Sent (View Workflow)
    • Major
    • Resolution: Unresolved
    • 26.0.0.Final
    • None
    • Security

    Description

      The test API https://github.com/wildfly/wildfly/blob/main/testsuite/integration/elytron/pom.xml#L58 org.xipki.pki/ocsp-server is not compatible with the latest bouncycastle https://issues.redhat.com/browse/WFCORE-5759 1.70 due to a incompatible change.

      A major upgrade to 5.3.14 is necessary to https://github.com/xipki/xipki/blob/v5.3.14/pom.xml#L36 which has new maven coordinates https://mvnrepository.com/artifact/org.xipki/ocsp-server.

      The temporary pinning of the version 1.69 for the test must be removed WFLY-16155

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              xf01213 Boris Unckel
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: