Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-14573

kubernetes.KUBE_PING can repeat WARN "failed getting JSON response from Kubernetes Client"

    XMLWordPrintable

Details

    • Hide

      1. Setup jgroups to use kubernetes.KUBE_PING protocol, e.g. in standalone-ha.xml:

              <subsystem xmlns="urn:jboss:domain:jgroups:7.0">
                  <channels default="ee">
                      <channel name="ee" stack="tcp" cluster="ejb"/>
                  </channels>
                  <stacks>
                      <stack name="tcp">
                          <transport type="TCP" socket-binding="jgroups-tcp"/>
                          <protocol type="kubernetes.KUBE_PING"/>
                          <protocol type="MERGE3"/>
                          <socket-protocol type="FD_SOCK" socket-binding="jgroups-tcp-fd"/>
                          <protocol type="FD_ALL"/>
                          <protocol type="VERIFY_SUSPECT"/>
                          <protocol type="pbcast.NAKACK2"/>
                          <protocol type="UNICAST3"/>
                          <protocol type="pbcast.STABLE"/>
                          <protocol type="pbcast.GMS"/>
                          <protocol type="MFC"/>
                          <protocol type="FRAG3"/>
                      </stack>
                  </stacks>
      ...
      

      2. deploy the wildfly-quickstart helloworld

      Show
      1. Setup jgroups to use kubernetes.KUBE_PING protocol, e.g. in standalone-ha.xml : <subsystem xmlns= "urn:jboss:domain:jgroups:7.0" > <channels default = "ee" > <channel name= "ee" stack= "tcp" cluster= "ejb" /> </channels> <stacks> <stack name= "tcp" > <transport type= "TCP" socket-binding= "jgroups-tcp" /> <protocol type= "kubernetes.KUBE_PING" /> <protocol type= "MERGE3" /> <socket-protocol type= "FD_SOCK" socket-binding= "jgroups-tcp-fd" /> <protocol type= "FD_ALL" /> <protocol type= "VERIFY_SUSPECT" /> <protocol type= "pbcast.NAKACK2" /> <protocol type= "UNICAST3" /> <protocol type= "pbcast.STABLE" /> <protocol type= "pbcast.GMS" /> <protocol type= "MFC" /> <protocol type= "FRAG3" /> </stack> </stacks> ... 2. deploy the wildfly-quickstart helloworld
    • ---
    • ---

    Description

      When staring EAP 7.3 image without using a template, kubernetes.KUBE_PING is configured by default. And it repeats the following WARN message "failed getting JSON response from Kubernetes Client" periodically (30-seconds intervals).
      Even if the clustering feature is not needed and OPENSHIFT_KUBE_PING_NAMESPACE environment variable is removed and unspecified, the same WARN message will be output.

      (Note: If template is used, dns.DNS_PING is configured with DNS Ping service and such WARN is not shown.)

      16:10:10,147 WARN  [org.jgroups.protocols.kubernetes.KUBE_PING] (thread-6,null,localhost) failed getting JSON response from Kubernetes Client[masterUrl=https://null:0/api/v1, headers={}, connectTimeout=5000, readTimeout=30000, operationAt
      tempts=3, operationSleep=1000, streamProvider=org.jgroups.protocols.kubernetes.stream.TokenStreamProvider@715f1f7f] for cluster [ee], namespace [default], labels [null]; encountered [java.lang.Exception: 3 attempt(s) with a 1000ms sleep t
      o execute [OpenStream] failed. Last failure was [java.net.UnknownHostException: null]]                                                                                                                                                       
      16:10:56,311 WARN  [org.jgroups.protocols.kubernetes.KUBE_PING] (thread-9,ee,localhost) failed getting JSON response from Kubernetes Client[masterUrl=https://null:0/api/v1, headers={}, connectTimeout=5000, readTimeout=30000, operationAtte
      mpts=3, operationSleep=1000, streamProvider=org.jgroups.protocols.kubernetes.stream.TokenStreamProvider@715f1f7f] for cluster [ee], namespace [default], labels [null]; encountered [java.lang.Exception: 3 attempt(s) with a 1000ms sleep to 
      execute [OpenStream] failed. Last failure was [java.net.UnknownHostException: null]]                                                                                                                                                         
      16:11:31,618 WARN  [org.jgroups.protocols.kubernetes.KUBE_PING] (thread-9,ee,localhost) failed getting JSON response from Kubernetes Client[masterUrl=https://null:0/api/v1, headers={}, connectTimeout=5000, readTimeout=30000, operationAtte
      mpts=3, operationSleep=1000, streamProvider=org.jgroups.protocols.kubernetes.stream.TokenStreamProvider@715f1f7f] for cluster [ee], namespace [default], labels [null]; encountered [java.lang.Exception: 3 attempt(s) with a 1000ms sleep to 
      execute [OpenStream] failed. Last failure was [java.net.UnknownHostException: null]] 
      

      A similar issue was reported as CLOUD-1957 before. And openshift.KUBE_PING has been changed not to repeat the WARN message but output only once by this fix. So, the above WARN message does not repeat with openshift.KUBE_PING in EAP 7.2 image.

      I think we may incorporate a similar change to jgroups-kubernetes.

      Attachments

        Issue Links

          Activity

            People

              thofman Tomas Hofman
              thofman Tomas Hofman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: