Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-14219

Utilize JBoss Modules version 1.9 in module descriptors

    XMLWordPrintable

Details

    Description

      There are still modules which use 1.5, 1.6 or 1.7 and do not need that. The idea is to run jdeps on each artifact of a modul, add the relevant java.* and jdk.* modules to the dependencies of the module and upgrade to version 1.8. In a first change only none-jdk modules and none which depend on system dependency.
      List in 2020-12-13_wildfly-22.0.0.Beta1-SNAPSHOT_modules_15_16_17.txt

      Changes in a first set of modules in WildFly-Core WFCORE-5229 integration tests were successful.

      Attachments

        Issue Links

          Activity

            People

              xf01213 Boris Unckel
              xf01213 Boris Unckel
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: