Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-13808

Make HTTP server available during deployment when starting up

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate Issue
    • Affects Version/s: 20.0.1.Final
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      HTTP server isn't available during deployment when Wildfly is starting up. That behavior is a feature, so that HTTP server is not serving until application isn't fully deployed. That behavior causes us trouble, because we have EAR with multiple services in WARs which communicate with each other during deployment phase.

      That was introduced in Wildfly 11 and is still present in 20.0.1. I think, that this wasn't intended to behave by default (see start suspended or start normal) https://github.com/wildfly/wildfly/blob/master/docs/src/main/asciidoc/_admin-guide/management-tasks/Suspend%2C_Resume_and_Graceful_shutdown.adoc Those settings actually make no difference - it starts suspended in both cases (only admin-only is honored correctly).

      I was poking around the source code (see diff.patch) and made small changes in wildfly-core to make it work, but AbstractControllerService would need to be if-elsed by desired start mode.

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              brian.stansberry Brian Stansberry
              Reporter:
              lojze.blatnik Alojzij Blatnik (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: