Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-13584

Require a minimum of Maven 3.6.0 and default to 3.6.3

    Details

      Description

      The current minimum Maven version is 3.3.0 which is quite old at this point. A minimum of 3.6.0 should be required with mvnw defaulting to the latest, 3.6.3.

      As part of this change we should remove the max heap from the .mvn/jvm.config. This config is picked up by maven as of 3.3.1 making it hard to override for environments like CI, http://maven.apache.org/configure.html#mvn-jvm-config-file.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jamezp James Perkins
                  Reporter:
                  jamezp James Perkins
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: