Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-5966 Validate requirement for modules previously exported by javax.ejb.api
  3. WFLY-13171

Validate requirement for modules previously exported by javax.ejb.api on JSF implementations

    XMLWordPrintable

    Details

      Description

      Validate the need of these module dependencies in the following modules:

      Modules:
      jsf/multi-jsf-installer/src/main/resources/mojarra-impl-module.xml
      jsf/multi-jsf-installer/src/main/resources/myfaces-impl-module.xml
      feature-pack/src/main/resources/modules/system/layers/base/com/sun/jsf-impl/main/module.xml

      Dependencies:

      <module name="javax.xml.rpc.api"/>
      <module name="javax.rmi.api"/>
      

      Additionally, remove javaee.api dependency and use only the required ones for the following test modules:

      jsf/subsystem/src/test/resources/modules/com/sun/jsf-impl/main/module.xml
      jsf/subsystem/src/test/resources/modules/com/sun/jsf-impl/myfaces/module.xml
      jsf/subsystem/src/test/resources/modules2/com/sun/jsf-impl/myfaces2/module.xml

      <module name="javaee.api"/>
      

        Attachments

          Activity

            People

            Assignee:
            yborgess1@redhat.com Yeray Borges Santana
            Reporter:
            yborgess1@redhat.com Yeray Borges Santana
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: