Uploaded image for project: 'WildFly'
  1. WildFly
  2. WFLY-10

jboss-cli deploy --force fails for OSGi bundles

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 8.0.0.Alpha1
    • Component/s: CLI, OSGi
    • Labels:
      None
    • Steps to Reproduce:
      Hide

      [standalone@localhost:9999 /] deploy C:\mypath\target\service-1.0-SNAPSHOT.jar
      'service-1.0-SNAPSHOT.jar' already exists in the deployment repository (use --force to replace the existing content in the repository).
      [standalone@localhost:9999 /] deploy C:\mypath\target\service-1.0-SNAPSHOT.jar --force
      {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"service-1.0-SNAPSHOT.jar\".CONFIGURE_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"service-1.0-SNAPSHOT.jar\".CONFIGURE_MODULE: JBAS018733: Failed to process phase CONFIGURE_MODULE of deployment \"service-1.0-SNAPSHOT.jar\"
      Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.module.spec.service.\"deployment.service-1.0-SNAPSHOT.jar\".main is already registered"}}

      Show
      [standalone@localhost:9999 /] deploy C:\mypath\target\service-1.0-SNAPSHOT.jar 'service-1.0-SNAPSHOT.jar' already exists in the deployment repository (use --force to replace the existing content in the repository). [standalone@localhost:9999 /] deploy C:\mypath\target\service-1.0-SNAPSHOT.jar --force {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"service-1.0-SNAPSHOT.jar\".CONFIGURE_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"service-1.0-SNAPSHOT.jar\".CONFIGURE_MODULE: JBAS018733: Failed to process phase CONFIGURE_MODULE of deployment \"service-1.0-SNAPSHOT.jar\" Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.module.spec.service.\"deployment.service-1.0-SNAPSHOT.jar\".main is already registered"}}

      Description

      If you try to deploy already-deployed .jar from cli, it says "already exists in the deployment repository (use --force to replace the existing content in the repository)". However, using --force errors with "service already registered" if it is an OSGi bundle.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  thomas.diesler Thomas Diesler
                  Reporter:
                  jrantav Jarkko Rantavuori
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: