I used the interface name "CapabilityContext" for the thing that defines the scope in which a capability is registered. Bad name, particularly now that the
WFCORE-834 work has introduced a "CapabilityResolutionContext" object for storing temp data used during capability resolution. The 834 thing is much more of a context.
So let's rename it to CapabilityScope.