Uploaded image for project: 'WildFly Core'
  1. WildFly Core
  2. WFCORE-5122

Enable TLS 1.3 by default for the WildFly OpenSSL provider

    XMLWordPrintable

Details

    • Task
    • Status: Open (View Workflow)
    • Major
    • Resolution: Unresolved
    • None
    • None
    • None
    • None

    Description

      WFCORE-4842 added support for TLS 1.3 for the WildFly OpenSSL provider but left TLS 1.3 disabled by default if no TLS 1.3 cipher suites have been configured by the user.

      Relevant commit: https://github.com/wildfly/wildfly-core/pull/4271/commits/12c7c835551b2e156cbe4ad88e1e2eb70f9fc441

      Once we are ready to do so, we should enable TLS 1.3 by default.

      Attachments

        Issue Links

          Activity

            People

              fjuma1@redhat.com Farah Juma
              fjuma1@redhat.com Farah Juma
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated: