Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-972

Weld does not build from source: Could not find artifact org.jboss.as:jboss-as-arquillian-common:jar:7.1.0.Alpha1-SNAPSHOT

    XMLWordPrintable

Details

    • Task
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Done
    • 1.1.2.Final
    • 1.1.3.Final
    • None
    • None

    Description

      It shouldn't be required to build another git repo from source first.

      The build fails with:

      [ERROR] Failed to execute goal on project weld-core-test: Could not resolve dependencies for project org.jboss.weld:weld-core-test:jar:1.1.3-SNAPSHOT: Could not find artifact org.jboss.as:jboss-as-arquillian-common:jar:7.1.0.Alpha1-SNAPSHOT in jboss-public-repository-group (http://repository.jboss.org/nexus/content/groups/public) -> [Help 1]
      

      Coming from:

            <jbossas7.version>7.1.0.Alpha1-SNAPSHOT</jbossas7.version>
      

      There are apparently no 7.1.0 snapshots being deployed of arquillian:
      https://repository.jboss.org/nexus/index.html#nexus-search;quick~jboss-as-arquillian-common

      Probably it's just a matter of configuring a hudson job on arquillian that deploys snapshot's to the jboss nexus maven repository.

      Attachments

        Activity

          People

            ajustin@redhat.com Ales Justin
            gdesmet@redhat.com Geoffrey De Smet
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: