Uploaded image for project: 'Weld'
  1. Weld
  2. WELD-2706

Adopt Weld 3/4 testing to WFLY changes

    XMLWordPrintable

Details

    • Task
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Done
    • 3.1.8.Final, 4.0.2.Final
    • 3.1.9.Final, 4.0.3.Final
    • None
    • None

    Description

      Wildfly is upgrading to EE 10/JDK 11.

      See also https://www.wildfly.org/news/2022/01/21/WildFly-2022/

       

      This means that WFLY 26 is the last we can consume for EE 8 and EE 9 testing for Weld 3 and Weld 4 respectively. We need to adapt the CI to those versions and verify that it works.

       

      Furthermore, Weld 5 will soon be able to renew incontainer testing with WFLY - as soon as they start upgrading components - and it will no longer need to consume preview variant (although it might?). It should stay on nightly tho.

      Attachments

        Activity

          People

            manovotn Matěj Novotný
            manovotn Matěj Novotný
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: