Details

    • Steps to Reproduce:
      Hide

      Check out the 3.1.3.Final tag of weld/weld-core and build it. Compare the MANIFEST.MF file of the resultant weld-osgi-bundle jar to that of the 3.1.2.Final weld-osgi-bundle jar.

      Show
      Check out the 3.1.3.Final tag of weld/weld-core and build it. Compare the MANIFEST.MF file of the resultant weld-osgi-bundle jar to that of the 3.1.2.Final weld-osgi-bundle jar.

      Description

      Between Weld 3.1.2 and Weld 3.1.3 the required version of javax.ejb dropped from [3.2,4) to [2.0,3). This seems to me like a bug, since that's a big drop in version and means this artefact can't be used by Java/Jakarta EE 8 application servers (e.g. Payara, GlassFish) since they provide EJB 3.2.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pandrex247 Andrew Pielage
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: