Uploaded image for project: 'Red Hat 3scale API Management'
  1. Red Hat 3scale API Management
  2. THREESCALE-7340

Migrate Webpack 4 to Shakapacker

    XMLWordPrintable

Details

    • Task
    • Status: Developing (View Workflow)
    • Major
    • Resolution: Unresolved
    • None
    • None
    • System
    • None
    • False
    • False
    • Not Started
    • Not Started
    • Not Started
    • Not Started
    • Not Started
    • Not Started
    • Undefined

    Description

      We should upgrade webpacker gem and webpack npm package to v5 (and eventually to v6)

      In order to be able to upgrade we first need to upgrade to Rails 5.2 and Node 12.

      Once Rails 5.2 and Node 12 are ready, we should:

      1. Update webpacker / webpack to latest 4.X and every single plugin, loader, libs, etc...
      2. Upgrade to webpacker 5 , then run webpacker isntalll, then probably upgrade webpack with yarn
      3. Update every loader, lib, etc... again
      4. build packs, fix errors and
      5. click test
      6. After v5 is running, upgrade to v6, if possible.

      Attachments

        Issue Links

          Activity

            People

              jgallaso Jose Miguel Gallas Olmedo
              damianpm Damian Peralta (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated: