Uploaded image for project: 'Red Hat 3scale API Management'
  1. Red Hat 3scale API Management
  2. THREESCALE-10683

Bump Operator Dependencies in 3scale Operator

XMLWordPrintable

    • RHOAM Sprint 53, RHOAM Sprint 54, RHOAM Sprint 55

      WHAT
      Bump Go version and Operator SDK to latest version for RHOAM and all dependent Operators:

      Minimum Target Versions
      Operator SDK 1.33 (This will done in follow up ticket THREESCALE-10997)
      Go 1.20
      API Machinery: 0.27 see thread
      Controller Runtime: Whatever is compatible with API Machinery (probably 0.15)

      We need to verify API Machinery: 0.27 does not contain goproxy

      NOTE
      Bump to minimum but bring as far forward as we can without too much headache

      HOW
      A good starting point for this work is to follow the Operator-SDK Upgrade guide:

      This will require some changes on midstream also - go image version and possibly the way bundles are built.

      DONE
      Verify that Operator is working on CPaaS

            Unassigned Unassigned
            bgallagh@redhat.com Brian Gallagher
            Martin Kudlej Martin Kudlej
            Carl Kyrillos Carl Kyrillos
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Created:
              Updated: