Uploaded image for project: 'Teiid Designer'
  1. Teiid Designer
  2. TEIIDDES-2242

If default Teiid runtime is set to version < 8.0 check VDB and warn user if VDB was created for >= 8.0

    Details

      Description

      Because of the changes to the vdb-deployer.xsd Schema in Teiid 8.x, VDB's containing data roles that include the grant-all = TRUE property will result in a SAX parser exception during the admin.getVDBs() call. This will happen in Designer server refresh and probably in the console if the VDB actually gets deployed.

      org.xml.sax.SAXParseException; lineNumber: 45; columnNumber: 115; cvc-complex-type.3.2.2: Attribute 'grant-all' is not allowed to appear

      If the Default Teiid Instance is < 8.0, then we should check prior to deployment to see if the VDB contains the validationVersion property which exists for ALL VDBs created in Teiid Designer 8.2+. If the property exists, then we can WARN the user that they should not deploy to an older server.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                blafond Barry LaFond
                Reporter:
                blafond Barry LaFond
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: