Uploaded image for project: 'Red Hat Process Automation Manager'
  1. Red Hat Process Automation Manager
  2. RHPAM-4219

Custom tasks not showing icon when it was installed via business central UI

    XMLWordPrintable

Details

    • False
    • None
    • False
    • Hide

      Edit Rest.wid and set Rest.png as an icon.

       

      "icon" : "Rest.png"   
      

       

      Show
      Edit Rest.wid and set Rest.png as an icon.   "icon" : "Rest.png"     
      1. create new project
      2. open Settings tab and clik Custom Tasks in left pane
      3. click Install button for Rest service and save it
      4. crate new process and select Custom Tasks icon in the left palette

    Description

      In process designer(stunner), services task icon is not shown when service task was installed via 7.12.0 Business Central UI: 
      Settings > Custom Tasks and click Install button.
       
      When installing Rest service task, the following WID and icon image will be created.
       
      global
      ├── Rest.png
      └── Rest.wid
       
      But in Rest.wid, 

              [
                  "name" : "Rest",
                  "displayName" : "Rest",
                  "category" : "jbpm-workitems-rest",
                  "description" : "",
                  "defaultHandler" : "mvel: new org.jbpm.process.workitem.rest.RESTWorkItemHandler()",
                  "documentation" : "jbpm-workitems-rest/index.html",            "parameters" : [
                                      "Cookie" : new StringDataType()
                      ,"ConnectTimeout" : new StringDataType()
                      ,"ResultClass" : new StringDataType()
                      ,"ContentType" : new StringDataType()
                      ,"AcceptCharset" : new StringDataType()
                      ,"Headers" : new StringDataType()
                      ,"AuthUrl" : new StringDataType()
                      ,"CookiePath" : new StringDataType()
                      ,"Method" : new StringDataType()
                      ,"ReadTimeout" : new StringDataType()
                      ,"Url" : new StringDataType()
                      ,"ContentTypeCharset" : new StringDataType()
                      ,"HandleResponseErrors" : new StringDataType()
                      ,"ContentData" : new StringDataType()
                      ,"Username" : new StringDataType()
                      ,"Content" : new StringDataType()
                      ,"AcceptHeader" : new StringDataType()
                      ,"AuthType" : new StringDataType()
                      ,"Password" : new StringDataType()            ],
                  "results" : [
                                      "Result" : new StringDataType()            ],
                  "mavenDependencies" : [
                                       "org.jbpm:jbpm-workitems-rest:7.59.0.Final-redhat-00006"            ],
                  "icon" : "defaultresticon.png"        ]]
      

       

      "defaultresticon.png" is set to icon which seems to be a cause of  missing icon.
      Same problem happens with the other service tasks, such as webservice,  as well. 
       

      Attachments

        Activity

          People

            romartin@redhat.com Roger Martinez
            rhn-support-hmiura Hiroko Miura
            Barbora Siskova Barbora Siskova
            Barbora Siskova Barbora Siskova
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated: