Uploaded image for project: 'Red Hat Process Automation Manager'
  1. Red Hat Process Automation Manager
  2. RHPAM-2060

Infinite "Configuration file does not exist" messages in Smart Router logs

    XMLWordPrintable

    Details

      Description

      I am using RHPAM 7.3 prod template on OCP 3.11, started like this:

      oc new-app -f rhpam73-prod.yaml -p JAVA_OPTS_APPEND='-Dorg.demo.jbpm.mobile.emailProvider=gmail -Dorg.demo.jbpm.mobile.emailRecipient=agiertli@redhat.com' -p KIE_ADMIN_USER=workbenchUser -p KIE_ADMIN_PWD=password1! -p KIE_SERVER_USER=kieServerUser -p KIE_SERVER_PWD=password1! -p BUSINESS_CENTRAL_HTTPS_KEYSTORE=central.jks -p BUSINESS_CENTRAL_HTTPS_SECRET=central-secret -p BUSINESS_CENTRAL_HTTPS_NAME=central -p BUSINESS_CENTRAL_HTTPS_PASSWORD=password1! -p KIE_SERVER_HTTPS_NAME=kieserver -p KIE_SERVER_HTTPS_PASSWORD=password1! -p KIE_SERVER_HTTPS_SECRET=kieserver-app-secret -p KIE_SERVER_ROUTER_HTTPS_SECRET=router-secret -p KIE_SERVER_ROUTER_HTTPS_NAME=router -p KIE_SERVER_ROUTER_HTTPS_KEYSTORE=router.jks -p KIE_SERVER_ROUTER_HTTPS_PASSWORD=password1! -p KIE_SERVER_MODE=DEVELOPMENT -p IMAGE_STREAM_NAMESPACE=pam-trial -p BUSINESS_CENTRAL_MONITORING_CONTAINER_REPLICAS=1 -p SMART_ROUTER_CONTAINER_REPLICAS=1 -p KIE_SERVER_CONTAINER_REPLICAS=1 -p MAVEN_REPO_URL=http://nexus-pam-trial.apps.waterford-5265.openshiftworkshop.com/content/repositories/snapshots -p MAVEN_REPO_USERNAME=admin -p MAVEN_REPO_PASSWORD=admin123
      

      In clean installation, right after the start, I can see following messages in the smart router log, going on infinitely:

      Apr 17, 2019 6:42:05 AM org.kie.server.router.repository.ConfigFileWatcher run
      WARN: configuration file does not exists /opt/rhpam-smartrouter/data/kie-server-router.json
      Apr 17, 2019 6:42:35 AM org.kie.server.router.repository.ConfigFileWatcher run
      WARN: configuration file does not exists /opt/rhpam-smartrouter/data/kie-server-router.json
      Apr 17, 2019 6:43:05 AM org.kie.server.router.repository.ConfigFileWatcher run
      WARN: configuration file does not exists /opt/rhpam-smartrouter/data/kie-server-router.json
      

      Can these be suppressed?

      PS: These messages disappears when I deploy some container on kie-server

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mauriciomag Mauricio Magnani
              Reporter:
              anton.giertli Anton Giertli
              Tester:
              Karel Suta Karel Suta
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: