Uploaded image for project: 'Red Hat Process Automation Manager'
  1. Red Hat Process Automation Manager
  2. RHPAM-1956

Task List 'Active Filters' indicator not in sync with Filters panel checkboxes

    Details

    • Target Release:
    • Steps to Reproduce:
      Hide
      1. navigate to tasks list
      2. select a few checkboxes in Filters
      3. Navigate to Saved Filters
      4. Navigate back to Filters
      5. See, that 'Active filters' still contain correct values, but checkboxes are not checked anymore
      Show
      navigate to tasks list select a few checkboxes in Filters Navigate to Saved Filters Navigate back to Filters See, that 'Active filters' still contain correct values, but checkboxes are not checked anymore
    • Sprint:
      2019 Week 23-25, 2019 Week 26-28, 2019 Week 29-31, 2019 Week 32-34

      Description

      There is inconsistency between what Active filters show and what checkboxes are selected.

      It seems that root cause is navigation between 'Filters' and 'Saved Filters' side panel. Once user configures filter in Filters, then even saves it, navigates to the Saved Filters and back to Filters (withou activating the saved filter), the filter criteria are still present in 'Active filters' indicator, but the checkboxes in Filters panel are not checked anymore.

      See the initial part of

      The issue prevents incremental configuration of filters or editing of existing filters.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                cory.bai Xiaofeng Bai
                Reporter:
                jstastny Jan Stastny
                Tester:
                Jan Stastny
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: