Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Do
    • Affects Version/s: 6.0.3, 6.4.0
    • Fix Version/s: None
    • Component/s: Eclipse Tooling
    • Labels:
      None

      Description

      Description of problem:
      When special characters are inputted into specific fields, they are not preserved. Some inputs are corrupting process completely - i.e. unable to open.

      Version-Release number of selected component (if applicable):
      JBDS Version: 7.1.1.GA
      +
      BPMN2 Modeler - Diagram Editor 1.0.2.201402102317 org.eclipse.bpmn2.modeler.feature.feature.group Eclipse.org
      How reproducible:
      always

      Steps to Reproduce:

      1) Set Characters(See attached fie: Characters.txt) into "Description -> Attributes -> Name" or "Process -> Attributes -> Id".
      2) Save the process, close it, open it again

      Following cases are causing the issue:

      Characters1) Characters1 is changed to Characters2.
      Characters3) Nothing in Name field. Characters3 is changed Characters4 in Id field.
      Characters5) I can't open BPMN file.(See attached fie: Fig1.png)

      Actual results:

      Process is getting modified/corrupted
      Expected results:
      Special characters are not causing any "harm" to the process definition

      Additional info:

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                manaRH Marek Novotny
                Reporter:
                anton.giertli Anton Giertli
                Involved:
                Anton Giertli, Jozef Marko, Robert (Bob) Brodt
                Tester:
                Dominik Hanak
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: