Uploaded image for project: 'OpenShift Request For Enhancement'
  1. OpenShift Request For Enhancement
  2. RFE-1329

Capability to install a specific version of operator from the Operator hub and to downgrade the operator

    XMLWordPrintable

Details

    • Feature Request
    • Resolution: Done
    • Normal
    • None
    • None
    • OLM
    • False
    • False
    • 0
    • 0% 0%
    • Undefined

    Description

      1. Proposed title of this feature request-- Capability to install a specific version of the operator from the Operator hub and to downgrade the operator version.
        2. What is the nature and description of the request? – Currently, there is no way to downgrade an operator. If the updated version has any issue then we need to wait till the issue gets fixed. Only the latest version available for any update channel can be installed from Operator Hub.
        3. Why does the customer need this? (List the business requirements here)-- in FISC guideline, when updating software, it is advised to prepare an update process including a recovery method. Hence, without the downgrade feature, OCP might be excluded from customer selection in the Japanese Financial market. 

               it is a common practice to downgrade the software version until the issue is fixed. However,  OCP doesn't allow users to do so.

              CU was not able to use the logging feature for two months until the problem described in the  Bugzilla[1] was resolved. Also, there was no workaround.

       [ 1] https://bugzilla.redhat.com/show_bug.cgi?id=1835396

      4. List any affected packages or components.-- Operators

      Attachments

        Issue Links

          Activity

            People

              DanielMesser Daniel Messer
              rhn-support-asheth Abhishek Sheth
              Votes:
              4 Vote for this issue
              Watchers:
              16 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: