It should be dead simple to make a planning entity immovable if a boolean field on it is true.
Almost everybody needs this and the movableEntitySelectionFilter=... approach is too much work for something so common.
Instead we want:
Open question: how shall we call that annotation? @PlanningPinned or @PlanningLocked or @PlanningImmovable?