-
Task
-
Resolution: Done
-
Major
-
None
-
NEW
-
NEW
This is a list of all unimportant backwards incompatible changes for 7.0. It's very unlikely that users will run into any of these because they are on exotic cases and because the upgrade recipe has mentioned each of them
https://github.com/droolsjbpm/optaplanner/blob/master/optaplanner-distribution/src/main/assembly/filtered-resources/UpgradeFromPreviousVersionRecipe.txt
This is the list:
Remove the method AbstractUncountableValueRange.isEmpty()Remove CustomShadowVariable.Source in favor of PlanningVariableReferenceFail fast in AbstractFromPropertyValueRangeDescriptor.processValueRangeProviderAnnotation() if the value range's Collection is unparameterized.Remove DeciderScoreComparatorFactoryConfigetcRemove deprecated ScoreHolder.setHardScore() etc
- incorporates
-
PLANNER-602 Remove <scoreDefinitionType> from the solver configuration
- Resolved
-
PLANNER-631 Engine: indictmentMap (reverse of ConstraintMatch's justificationList) for visualization and Guided Local Search
- Resolved
-
PLANNER-611 Move.doMove() must return undo move to allow CompositeMove to return a correct undo move
- Resolved
-
PLANNER-403 Rename before/afterProblemFactChanged to before/afterProblemPropertyChanged
- Resolved
-
PLANNER-518 Take advantage of Java 8: remove java.util.Date usage
- Resolved
-
PLANNER-539 Actively try to reduce usage of commons and guava dependencies when upgrading to Java 7 and 8
- Resolved
-
PLANNER-405 Score should keep track of the uninitialized variable count
- Resolved
-
PLANNER-227 Variables of primitive types should be illegal because Construction Heuristics consider them initialized (even if they are their default value)
- Resolved
-
PLANNER-526 BendableScore.toString() must include "hard" "soft" seperation
- Resolved
-
PLANNER-546 Make use of try (InputStream in = ...) {} instead of finally {IOUtils.closeQuietly(in);}
- Resolved
-
PLANNER-598 Benchmark output xml file should reuse optaplanner-xstream's ScoreConverter
- Resolved
-
PLANNER-632 ConstraintMatch and ConstraintMatchTotal should be able to return a Score instead of an int scoreLevel and weight
- Resolved
-
PLANNER-746 Rename locateWorkingObject() to lookUpWorkingObject(), relocate() to rebase() and Locator to LookUpManager
- Resolved
-
PLANNER-748 Score.toShortString() that gives "-5soft" for "0hard/-5soft"
- Resolved
- is related to
-
PLANNER-478 Replace LinkedList by ArrayDeque wherever appropriate
- Resolved
-
PLANNER-483 Use MethodHandles or Javassist Proxies instead of traditional reflection in 7.0 to reduce reflection performance cost
- Resolved
- relates to
-
PLANNER-356 @ProblemFactCollectionProperty and @ProblemFactProperty to replace Solution method getProblemFacts()
- Resolved
-
PLANNER-436 Avoid having to implement the Solution interface because a @PlanningSolution, @Score and optional @ProblemFacts annotation could be enough
- Resolved