-
Enhancement
-
Resolution: Done
-
Major
-
None
-
None
-
2020 Week 40-42 (from Sep 28)
-
3
-
Undefined
-
NEW
-
NEW
Decided:
- Rename clearWorkingSolution(ScoreDirector) to close().
- Should VariableListener have resetWorkingSolution() and close()?
- Yes, but it must both be default methods.
- Can VariableListenerAdapter be removed?
- Yes, those methods can be made default
- Should StatefulVariableListener be public API?
- No, now that VariableListener gets those methods.
- Should we rename it?
- SourcedVariableListener
- Should the VariableListener javadoc mention it?
- No, purely internal.
- Should VariableListener implement Supply?
- No, if the following is yes:
- Can VariableListener not implement Supply, but SourcedVariableListener do implement Supply?
- Probably: because custom VariableListeners are never demanded as a supply and all internal onces should be SourcedVariableListener.
- Can VariableListener not implement Supply, but SourcedVariableListener do implement Supply?
- No, if the following is yes:
Delayed:
- Should the VariableListener methods be defaulted? Yes, the before* methods should be, can do later.
- Should Supply exist as an interface? Maybe.
- is related to
-
PLANNER-2203 Add <Solution_> type parameter to various impl classes
- Resolved