Uploaded image for project: 'OpenShift Over the Air'
  1. OpenShift Over the Air
  2. OTA-623

Ensure Admin Acknowledgement of API removals in 4.12

    XMLWordPrintable

Details

    • Epic
    • Resolution: Done
    • Blocker
    • openshift-4.12
    • None
    • None
    • Add 4.11-to-4.12 admin ack
    • False
    • None
    • False
    • Green
    • To Do
    • Impediment
    • 100
    • 100% 100%
    • Hide

      Progress is being made and Docs + OTA have all the known work is tracked.

      Show
      Progress is being made and Docs + OTA have all the known work is tracked.

    Description

      As an 4.11 cluster admin I am required to acknowledge API removals in Kubernetes 1.25 before upgrading to 4.12, so that I'm fully aprised of API removals assocated with upgrading to 4.12.

      Note, rather than last time where we drafted documentation and published it via KCS article we expect that we will be able to draft this documentation and publish it as part of 4.11 release notes in the deprecations and removals section.

      Note: Land this in a 4.11.z which is relatively close to the point at which we'd offer upgrades to 4.12. So perhaps Fix Version for the configmap itself should be a 4.12 fix version? The goal here is not to put the ACK in front of an admin before they can actually upgrade to 4.12, we want to avoid them acking immediately after upgrading to 4.11 and then not revisiting during the upgrade to 4.12.

      Attachments

        Issue Links

          Activity

            People

              lmohanty@redhat.com Lalatendu Mohanty
              rhn-support-sdodson Scott Dodson
              Evgeni Vakhonin Evgeni Vakhonin
              Andrea Hoffer Andrea Hoffer
              Votes:
              0 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: